| ブログトップ | WEB関連全般 |

PS Taxonomy Expanderでクイック編集ができなくなる件

PS Taxonomy Expanderというカテゴリの並び順を変更できるプラグインがあるのですが、最近のWordpressではクイック編集ができなくなるという不具合があります。

最終更新日が5年前ですから、動作保証外なのもしかたないですね。

他のプラグインに変更するべきではあるのですが、それで同じ挙動になればよいのですが、そううまくいかない場合もあります。

その場合は、クイック編集をあきらめるか、下記の方法で対応しましょう。

プラグインフォルダの中にある「ps-taxonomy-expander.php」をエディタで開きます。

33・34行目付近にある下記をコメントアウト。

add_action( 'admin_head-edit.php' , array( $this, 'remove_inline_edit_post_js' ) );
add_action( 'load-edit.php' , array( $this, 'add_sc_inline_edit_js' ) );

//add_action( 'admin_head-edit.php' , array( $this, 'remove_inline_edit_post_js' ) );
//add_action( 'load-edit.php' , array( $this, 'add_sc_inline_edit_js' ) );

これでクイック編集が動くようになります。

これらのフックが何をしているのかはわかりませんが、とりあえず動作に問題はなさそうなので、どうしてもPS Taxonomy Expanderを使い続ける必要があり、クイック編集を使いたい人は自己責任でお試しあれ。

日々の生活にhappyをプラスする|ハピタス

このエントリーをはてなブックマークに追加

LINEで送る

総合管理者 | 2021年03月15日 | コメント(0) | トラックバック(0) | WEB関連全般

トラックバック

トラックバックURL

コメントする

※メールアドレスが公開されることはありません。

名前 *
メール*
URL
Copyright(c) 2010 - 2021 ダリの雑記